To browser these website, it's necessary to store cookies on your computer.
The cookies contain no personal information, they are required for program control.
  the storage of cookies while browsing this website, on Login and Register.

Author Topic:  Server Code Compilation/Run  (Read 456 times)

0 Members and 1 Guest are viewing this topic.


« on: 26, November 2017, 14:32:08 »
Hi there,

I am trying to compile the server on my raspberry that is running the raspbian OS (based on Debian 9 Stretch)

The first problem that I got, was that using the -O0 flag, it can't find the inline functions, so I changed it to -O1 and was able to compile the server without problems.

The second problem was that when I run the make install, it skip some directories because the copy command on the install script is using the "cp" command without the recursive flag "-r", fixed that too!

Well, server compiled and installed on the local folder, not on the system, but when I try to run the server, it gives me this errors:

TIMESTAMP: 2017-11-26 12:22:55

Daimonin v0.10.8-b (protocol version 991031).
Copyright (C) 2002-2009 Michael Toennies.
Reading bmaps from ./lib/bmaps...done (got 9276/9277/9277)
Reading animations from ./lib/animations...
done. (got 759)
Reading archetypes from ./lib/archetypes...
 arch-pass 1...
 setting up archetable...done
 reading artifacts from ./lib/artifacts...MAPBUG: Object <no ->arch> - can't find face bracers_med_str.101.
 adding local artifacts from
 loading treasure...
BUG: Treasure lacks archetype: armour_ag
BUG: Treasure lacks archetype: bracers_ag
BUG: Treasure lacks archetype: boots_ag
BUG: Treasure lacks archetype: belt_ag
BUG: Treasure lacks archetype: pants_ag
BUG: Treasure lacks archetype: helmet_ag
BUG: Treasure lacks archetype: token_generic
BUG: Treasure lacks archetype: sphere_generic
BUG: Treasure lacks archetype: critter_generic
BUG: Treasure lacks archetype: tripyra_stone_generic
 adding local treasures from
 link treasure lists pass 2...
ERROR: Treasurelist armour_mail has element with no name or archetype
Fatal: Shutdown server. Reason: Fatal Error

I tried to compile the server code of the trunk and of the main branches!


server/make folder
make all
make install
back to server folder
chmod +x daimonin_server

« Last Edit: 26, November 2017, 14:35:08 by Foot »


« Reply #1 on: 27, November 2017, 01:00:31 »
I'm assuming you're referring to the "cp arch/* lib" command, which is meant to do just that: copy all files (not directories) from the arches directory. Because some of those files are essentially just compiled versions of all the directory contents. No harm done by copying the directories, though.

The error you're having could be one of two things. Either an arch is missing from the SVN (I can't check right now, someone else might be able to though) or you just need to rebuild the arch collection. There is a bash script at project_tools/bash_scripts/ which will be able to recollect them for you. After that, just run "cp arch/* server/lib/*" and your server will have the complete collection.

You can also use the mapmaker to collect arches, which is a bit faster and allows you to create/edit maps. Just download the editor package and add extract the file "editor/DaimoninEditor.jar" into <your Daimonin dir>/editor and run "java -jar DaimoninEditor.jar -c" and then "cp arch/* server/lib/*".
-- _people_ :)


« Reply #2 on: 27, November 2017, 14:42:57 »
Thanks, it worked!

Ran " path/arch path/lib"
Compiled the server with -O1, to fix de inline function
Ran ./daimonin-server, and now it worked without problem!



Related Topics

  Subject / Started by Replies Last post
6 Replies
Last post 24, March 2005, 23:36:42
by Rubinstein
2 Replies
Last post 22, July 2005, 12:27:36
by michtoen
2 Replies
Last post 15, July 2007, 12:16:12
by ThePlaneskeeper
8 Replies
Last post 12, May 2007, 02:30:42
by SirNarf
6 Replies
Last post 24, May 2007, 13:29:37
by jmaxou