Language: 
To browser these website, it's necessary to store cookies on your computer.
The cookies contain no personal information, they are required for program control.
  the storage of cookies while browsing this website, on Login and Register.

Linked Events

  • Happy Thanksgiving!: 16, November 2017 - 29, November 2017

Author Topic:  Thanksgiving Maps  (Read 340 times)

0 Members and 1 Guest are viewing this topic.

Joe

« on: 16, November 2017, 08:28:25 »
Gobble gobble!  Thanksgiving is here in Daimonin, have fun and remember to thank someone in your life.

Starts:  Now!

Ends:  Nov. 30th

Where:  Guildhall travel agency

myths

« Reply #1 on: 18, November 2017, 12:05:05 »
Thank you Joe for putting up the event map, it is appreciated.
Again I have the issue that the quests have not been reset and so can not participate in the quests which most of the fun for the event maps.
I understand if no one wants to reset the quests for a single returning player, just let me know if it does get done.
Otoh you could give me /SA status and let me reset the quests to ThanksgivingEvent2017 :D
It would be nice to get a red rose

smacky

« Reply #2 on: 18, November 2017, 14:59:46 »
I'll try the workaround I suggested last month in the shoutbox. But I can't conveniently set up a local test server so I'm going to do it live on main. I say "I". I mean "we". ;)

I know nothing of the events. First of all, for TG there are 4 quests:
* Turkey Time
* Lost Diary
* Fix the Bugs
* Get the Feathers

Yes? If so, which is the easiest one for you to talk to the quest giver of? Go stand near this NPC, post /mapinfo so I know where he is, and logout so your right there for the next step.

myths

« Reply #3 on: 18, November 2017, 16:12:00 »
Hello Smacky,
I have done exactly as you requested. The quest is 'Lost Diary'
I took a screen shot of the /mapinfo, all the info is in the chat box.
Here is the screen shot,
It would be nice to get a red rose

smacky

« Reply #4 on: 18, November 2017, 17:17:48 »
OK. This'll need a reboot. After that the quest offered should be 'Thanksgiving 2017: Lost Diary'.

If that works I'll do the same for other event quests.

A few points:

* Is Thanksgiving one word?

* This also renames the quest reward (from English Noble's Hat to English Noble's YYYY Hat). This should make such rewards more collectable/prestige items.

* The script obviously intends the hat to be egobindable. But does this work?

Joe

« Reply #5 on: 18, November 2017, 21:49:23 »
Thanksgiving - one word

The desk which holds the quest item Lost Diary doesn't work.  Map events/thanksgiving/mayflower_0001

The hat is egobound

smacky

« Reply #6 on: 18, November 2017, 22:21:28 »
The desk doesn't work? ::) I'll have a look tomorrow.

smacky

« Reply #7 on: 19, November 2017, 14:39:56 »
AFAICS there is nothing special about the desk. I was a bit too keen on renaming things in the script so the quest trigger  of the diary in the desk wasn't being recognized. Fixed. Do a reboot and hopefully it'll now work (you'll need to skip any previously accepted Thanksgiving 2017: Lost Diary quest via qlog and reaccept it).

NOTE: In order to minimize human maintenance of scripts I use the lua function os.date() to get the year:

* This ultimately relies on the server box being set correctly. So if it's the wrong year, this is why.

* The year changes on New Year's Day (no, really it does) so be careful of events that span that date. As in don't do them (eg, Xmas event runs from, say 2300 17/12 to 2300 31/12, not December to March, etc)...

myths

« Reply #8 on: 19, November 2017, 17:03:13 »
I just tried to do the Diary quest and I was given the quest however the desk still does not have the diary. This may be because the server has not been reset yet, IDK. If it has been reset then the desk is still broken. If it has not been reset then I will test the desk after the reset.
In any case, Ty Smacky for the help.
It would be nice to get a red rose

Joe

« Reply #9 on: 19, November 2017, 22:19:17 »
Had to watch my greenbay packers get killed, ok server has been restarted.

Looking into the desk I see the quest but not the book.
« Last Edit: 19, November 2017, 22:26:51 by Joe »

smacky

« Reply #10 on: 20, November 2017, 12:10:53 »
*sigh* I guess thid is in MM mode so you can ;see; sys objects (and in a closed desk?

Try doing the whole quest as a normal player.

If it doesn't work, start a new player and ddo Fanrir's Sack. That's the same type of quest so lets make sure it's not fundamentally broken

Joe

« Reply #11 on: 20, November 2017, 17:45:54 »
Tried as a normal player, it does not give the quest item book.  Franrir's sack gave the item as it should.

smacky

« Reply #12 on: 20, November 2017, 20:45:33 »
I realised the problem while fixing the Island scripts just now. Need to think. Might require an interim.

darkgardennerd

« Reply #13 on: 24, November 2017, 23:49:48 »
Please excuse this newbie here, I tried the steps above and I still cannot get to find the dairy. Im discovering this game and I'm liking it very much. I would love to help in some way not sure how. I'm a Javascript developer tho. ;)

smacky

« Reply #14 on: 25, November 2017, 16:55:47 »
Hi, yeah sorry. For now this quest doesn't work. I have a fix almost ready to go (patches server code and the utility scripts) but ATM I am a bit borked so I probably won't do the update this month (ie, not for TG Event).

Tags:
 

Related Topics

  Subject / Started by Replies Last post
15 Replies
5802 Views
Last post 23, November 2005, 15:54:36
by Unislash
12 Replies
949 Views
Last post 29, November 2007, 23:28:08
by Animegirl777
4 Replies
1804 Views
Last post 22, December 2009, 00:37:39
by _people_
14 Replies
3862 Views
Last post 15, November 2013, 18:18:51
by clobber
1 Replies
261 Views
Last post 26, November 2015, 22:17:00
by myths