Language: 
To browser these website, it's necessary to store cookies on your computer.
The cookies contain no personal information, they are required for program control.
  the storage of cookies while browsing this website, on Login and Register.

Author Topic:  Joes archs  (Read 2249138 times)

0 Members and 1 Guest are viewing this topic.

Joe

« Reply #630 on: 11, February 2019, 01:48:23 »
It's tricky working with the water arches.  For one they can't be animated since layer 1 and 2 items can not be.  Also atm they only use one image for all the water, so if I put a sparkle on one it shows on all of them.  Even the shoreline I've made are layer 2 but I cheated and made them layer 3 masks so they could be animated. 

Hopefully sometime in the future we can animate the water and have a really nice looking lake.

Joe

« Reply #631 on: 04, May 2019, 13:53:37 »
Working on adding shoreline arches


_people_

« Reply #632 on: 05, May 2019, 03:33:57 »
Something's off with the bridge area.



Looks like you're putting the water tiles above the normal floor layer. I'm assuming this means animations aren't allowed on floors? I'll have to fix that if so. I believe this is causing the issue because there's 2 different objects (shoreline masks and the water, which is acting as a mask) on the same layer.

Hmm, /resetmap fixed the issue but it still occurs sometimes when loading a new map. I also notice that when the player steps on the shore tiles (which shouldn't happen too often as only SA's/MM's should be standing there) they turn to black.

I'll have to find a way to update the client for this but I'll be away for a few weeks until June.

Another (minor) issue is that the animations aren't syncing between maps. This'll be much more difficult to fix but I think I may have a way to do so. It'll have to be part of the client overhaul though.
-- _people_ :)

Joe

« Reply #633 on: 05, May 2019, 05:26:04 »
Hmm, I'll have to turn the water anim off for now and set it as layer 1.  This was the problem as you mentioned, the layer 1 and 2 arches are not able to be animated.  I cheated and tried setting them as layer 3 but I'll change them back and wait for the update.

Seems funny though that it didn't work since I set the water as layer 3 and the shoreline as layer 4.

Got so excited for animated water I cheated a bit lol,  oops!

Tags:
 

Related Topics

  Subject / Started by Replies Last post
1 Replies
1331 Views
Last post 02, January 2006, 01:36:45
by Slash_Wraith
1 Replies
1191 Views
Last post 05, June 2006, 18:58:15
by Slash_Wraith
6 Replies
1884 Views
Last post 19, April 2006, 00:18:14
by Sherock
6 Replies
2575 Views
Last post 27, August 2006, 22:20:35
by Cleopatra2